Jbuilder 7 messed up my Win Registry
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   sa_wa
Posted On:   Friday, September 13, 2002 09:52 PM

I used to use j2sdk1.4 before I installed Jbuilder 7, everything was fine. Then I intalled Jbuilder 7. I added a JDK path for j2sdk1.4. My project runs well in Jbuilder. But I laterly found my bat file failed in DOS window, because some registry problem, here is my error message: ----------------------- C:MyProjects>java Registry key 'SoftwareJavaSoftJava Runtime EnvironmentCurrentVersion' has value '1.3', but '1.4' is required. Error: could not find java.dll Error: could not find Java 2 Runtime Environment. ---------------------- I checked my CLASSPATH and Path, there are no change. So how to fix this? Thanks in advance   More>>

I used to use j2sdk1.4 before I installed Jbuilder 7, everything was fine.



Then I intalled Jbuilder 7. I added a JDK path for j2sdk1.4. My project runs well in Jbuilder.



But I laterly found my bat file failed in DOS window, because some registry problem, here is my error message:

-----------------------


C:MyProjects>java

Registry key 'SoftwareJavaSoftJava Runtime EnvironmentCurrentVersion'
has value '1.3', but '1.4' is required.

Error: could not find java.dll

Error: could not find Java 2 Runtime Environment.

----------------------


I checked my CLASSPATH and Path, there are no change. So how to fix this?


Thanks in advance!

sawa.

   <<Less

Re: Jbuilder 7 messed up my Win Registry

Posted By:   Josef_Joller  
Posted On:   Tuesday, September 24, 2002 01:32 PM

It's easy, but annoying:

start the registry editor (Start>Run>regedit)

search for Javasoft

change to "Java Runtime Environment"
HKEY_LOCAL_MACHINESOFTWAREJavaSoftJava Runtime

Environment

check key : CurrentVersion (it's probably 1.3)

change it (click on keyname) to 1.4

exit regedit

now the error should not show up again.

Re: Jbuilder 7 messed up my Win Registry

Posted By:   Ranjan_Sinha  
Posted On:   Saturday, September 14, 2002 12:55 AM

Hi ,

I too had faced this problem. But settinng the registry entry
HKEY_LOCAL_MACHINESOFTWAREJavaSoftJava Runtime EnvironmentCurrentVersion back to 1.4 had solved this problem.
Hope this helps.
About | Sitemap | Contact