InitialContext with weblogic 6.1 deliveres Nullpointer on L10nLookup.loadProps
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Erik_Deibert
Posted On:   Tuesday, July 16, 2002 05:55 AM

I have a problem with getting an initialcontext within a weblogic 6 I have a problem with getting an initialcontext within a weblogic 6.1 environment via T3. code: Hashtable p = new Hashtable(); p.put(Context.PROVIDER_URL,"t3://:"); p.put(Context.INITIAL_CONTEXT_FACTORY, weblogic.jndi.WLInitialContextFactory.class.getName()); InitialContext _context = new InitialContext(p); error: Error -17999 : System.err: java.lang.NullPointerException Error System.err: at weblogic.i18ntools.L10nLookup.   More>>
I have a problem with getting an initialcontext within a weblogic 6







I have a problem with getting an initialcontext within a weblogic 6.1 environment via T3.



code:


Hashtable p = new Hashtable();


p.put(Context.PROVIDER_URL,"t3://:");


p.put(Context.INITIAL_CONTEXT_FACTORY, weblogic.jndi.WLInitialContextFactory.class.getName());


InitialContext _context = new InitialContext(p);



error:


Error -17999 : System.err: java.lang.NullPointerException Error


System.err: at weblogic.i18ntools.L10nLookup.loadProps(L10nLookup.java:106) Error


System.err: at weblogic.i18ntools.L10nLookup.init(L10nLookup.java:144) Error


System.err: at weblogic.i18ntools.L10nLookup.getL10n(L10nLookup.java:59) Error


System.err: at weblogic.logging.LogManager.open(LogManager.java:87) Error


System.err: at weblogic.kernel.Kernel.initialize(Kernel.java:108) Error


System.err: at weblogic.kernel.Kernel.ensureInitialized(Kernel.java:83) Error


System.err: at weblogic.jndi.WLInitialContextFactoryDelegate.(WLInitialContextFactoryDelegate.java:163) Error


System.err: at java.lang.Class.newInstance0(Native Method) Error


System.err: at java.lang.Class.newInstance(Class.java:232) Error


System.err: at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:147) Error


System.err: at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:671) Error


System.err: at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:242) Error


System.err: at javax.naming.InitialContext.init(InitialContext.java:218) Error


System.err: at javax.naming.InitialContext.(InitialContext.java:194) Error


System.err: at Actions.init(Actions.java:37) Error


System.err: java.lang.InternalError: error initializing kernel Error


System.err: at weblogic.kernel.Kernel.ensureInitialized(Kernel.java:86) Error


System.err: at weblogic.jndi.WLInitialContextFactoryDelegate.(WLInitialContextFactoryDelegate.java:163) Error


System.err: at java.lang.Class.newInstance0(Native Method) Error


System.err: at java.lang.Class.newInstance(Class.java:232) Error


System.err: at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:147) Error


System.err: at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:671) Error


System.err: at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:242) Error


System.err: at javax.naming.InitialContext.init(InitialContext.java:218) Error


System.err: at javax.naming.InitialContext.(InitialContext.java:194) Error


System.err: at Actions.init(Actions.java:37) Error


Error -17999 : java.lang.InternalError: error initializing kernel


Error -17999 : at weblogic.kernel.Kernel.ensureInitialized(Kernel.java:86)


at weblogic.jndi.WLInitialContextFactoryDelegate.(WLInitialContextFactoryDelegate.java:163)


at java.lang.Class.newInstance0(Native Method)


at java.lang.Class.newInstance(Class.java:232)


at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:147)


at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:671)


at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:242)


at javax.naming.InitialContext.init(InitialContext.java:218)


at javax.naming.InitialContext.(InitialContext.java:194)


at Actions.init(Actions.java:37)



Anyone know whats wrong???


   <<Less

Re: InitialContext with weblogic 6.1 deliveres Nullpointer on L10nLookup.loadProps

Posted By:   Anonymous  
Posted On:   Thursday, October 3, 2002 01:56 PM

I am getting the same error while trying to make an EJB call from an EJB deployed on EAServer to an other EJB on Weblogic. I am guessing that something in weblogic.jar conflicts with EAServer jars.

Re: InitialContext with weblogic 6.1 deliveres Nullpointer on L10nLookup.loadProps

Posted By:   Greg_Jacobi  
Posted On:   Thursday, September 5, 2002 03:04 PM

I am having the same problem. Did you ever get this resolved?

Thanks.

Re: InitialContext with weblogic 6.1 deliveres Nullpointer on L10nLookup.loadProps

Posted By:   Gautam_Marwaha  
Posted On:   Tuesday, July 16, 2002 11:22 PM

have you tried using:


p.put(Context.INITIAL_CONTEXT_FACTORY, "weblogic.jndi.WLInitialContextFactory");
About | Sitemap | Contact