XML Parser doesn't read in element tags (SAX Parsing)
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Andre_Kuhn
Posted On:   Tuesday, July 9, 2002 07:05 AM

Hi My application works fine on a Linux RedHat. But deployed on a different UNIX machine the XML parsing ouput goes like: " <> -Europe- <> -Nordic- <> -Denmark- <> -Finland- <> -Sweden- <> -Northern Europe- <> -Austria- etc..." instead of: " -Europe- -Nordic- -Denmark- etc..." Means, reading the element    More>>

Hi

My application works fine on a Linux RedHat.

But deployed on a different UNIX machine the XML parsing
ouput goes like:



			
				
"
<>
-Europe-
<>
-Nordic-
<>
-Denmark-
<>
-Finland-
<>
-Sweden-
<>
-Northern Europe-
<>
-Austria-

etc..."



instead of:



			
				
"

-Europe-


-Nordic-


-Denmark-


etc..."



Means, reading the element tag does not trigger the startElement method correctly. The endElement is left out at all.


The Parser gets initiated using a factory pattern:


			
				
m_Factory = SAXParserFactory.newInstance();

try
{
m_SaxParser = m_Factory.newSAXParser();
m_XMLReader = m_SaxParser.getXMLReader();
}
catch (Throwable t) { t.printStackTrace(); }



I guess, it is somehow involved with the XML parser
available at the (destination) UNIX machine.


I greatly appreciate responses    <<Less

Re: XML Parser doesn't read in element tags (SAX Parsing)

Posted By:   Roseanne_Zhang  
Posted On:   Monday, September 2, 2002 06:15 PM

Strange! Our application works on all different unix machines, and never need to change a single line of java code. Dom and Jdom code included. My best guess is you might have setting problems.



Do you use ant to set-up everything?

About | Sitemap | Contact