2.5.2. and external tool environment problem
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Colin_Froggatt
Posted On:   Thursday, April 18, 2002 01:18 AM

Hi, I recently upgraded to 2.5.2 (from 2.5.1). Under 2.5.1 I had an external tool defined for RMIregistry and this found my stub classes ok when required. Since upgrading to 2.5.2, this tool no longer finds the stub classes. The classes are present in the same place and the same tool def works fine under the 2.5.1 install. I have solved the problem by creating a batch file into which I pass the classpath and set the classpath before starting the registry. This is a bit clunky and I cannot kill the process from the IDE. From this I assume that the classpath was set in the process env in 2.5.1 but is not in 2.5.2. Is there any way to resolve this or make a tidier solution? Config: - Idea 2.5.2 build 5   More>>

Hi, I recently upgraded to 2.5.2 (from 2.5.1). Under 2.5.1 I had an external tool defined for RMIregistry and this found my stub classes ok when required. Since upgrading to 2.5.2, this tool no longer finds the stub classes. The classes are present in the same place and the same tool def works fine under the 2.5.1 install.


I have solved the problem by creating a batch file into which I pass the classpath and set the classpath before starting the registry. This is a bit clunky and I cannot kill the process from the IDE.


From this I assume that the classpath was set in the process env in 2.5.1 but is not in 2.5.2. Is there any way to resolve this or make a tidier solution?


			
Config:
- Idea 2.5.2 build 547 (running under jdk 1.3.1-03)
- Win 2K - SP 1
- Twin Proc 1Ghz Pentium III


This happens regardless of the dev JDK being used (122 or 131 etc).    <<Less

Re: 2.5.2. and external tool environment problem

Posted By:   Serge_Baranov  
Posted On:   Wednesday, April 24, 2002 06:22 AM

This happens because 2.5.2 uses InstallAnywhere which creates idea.exe and doesn't pass environment variables. A tider solution is to download zipped version of IDEA 2.5.2 and use it just like 2.5.1.


IntelliJ Support Team
About | Sitemap | Contact