Appending a message without sending it
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Rizwan_Sattar
Posted On:   Saturday, March 2, 2002 04:38 PM

Hello all, I'm having trouble with my Java mail client viewing the contents of the message when I dont' send the message to the IMAP Store, but instead just create it and append the Message to the folder. I am testing only with plain text. Using the same method to store plain text and then sending it to my inbox folder and viewing the message doesn't seem to cause any trouble, however. Is there something that is set while sending a message that is missing when you just append a newly created Message to folder? Here is the message which is not working: Message-ID: <16183958.1015115336874.JavaMail.javamailuser@localhost> From: filterPlugIn To: filterPlug   More>>


Hello all,



I'm having trouble with my Java mail client viewing the contents of the message when I dont' send the message to the IMAP Store, but instead just create it and append the Message to the folder.

I am testing only with plain text. Using the same method to store plain text and then sending it to my inbox folder and viewing the message doesn't seem to cause any trouble, however. Is there something that is set while sending a message that is missing when you just append a newly created Message to folder?



Here is the message which is not working:

			
Message-ID: <16183958.1015115336874.JavaMail.javamailuser@localhost>
From: filterPlugIn
To: filterPlugIn_Store
Subject: FilterPlugIn Configuration
Mime-Version: 1.0
X-Smart-Message-Id: none
X-Smart-Category: none
X-Smart-Language: en

<?xml version="1.0" encoding="UTF-8"?>


The message shows up fine in outlook express, but in my mail client i get


IOException: No Content


As you can see this is not a regular message, but a message that i am using to store information for a filter program that I am writing. Any ideas? Thanks


Rizwan Sattar

   <<Less

Re: Appending a message without sending it

Posted By:   Rizwan_Sattar  
Posted On:   Saturday, March 2, 2002 04:54 PM


Wait, sorry I was trying to load the body from the message profile and not the actual message. My mistake.


regards,

Rizwan Sattar

About | Sitemap | Contact