error using <jsp:include> in tomcat 4.0.1
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   virga_ramada
Posted On:   Friday, February 1, 2002 09:04 AM

when i try to include a jsp file using (i try both flush=true and no flush argument) directive in tomcat 4.0.1 generates these errors: org.apache.jasper.JasperException: Unable to compile class for JSP Generated servlet error: java:1293: Method include(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse, java.lang.String, javax.servlet.jsp.JspWriter, boolean) not found in class org.apache.jasper.runtime.JspRuntimeLibrary. JspRuntimeLibrary.include(request, response, "blah.jsp" + _jspx_qStr, out, true); it looks like a bug in tomcat 4.0.1, i didn't get these kind of error before (tomcat 3.2.4) i change to tomcat 4 because it supports request.setCharacterEncoding() method. so if    More>>

when i try to include a jsp file using (i try both flush=true and no flush argument) directive in tomcat 4.0.1 generates these errors:
org.apache.jasper.JasperException: Unable to compile class for JSP

Generated servlet error:
java:1293: Method include(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse, java.lang.String, javax.servlet.jsp.JspWriter, boolean) not found in class org.apache.jasper.runtime.JspRuntimeLibrary.
JspRuntimeLibrary.include(request, response, "blah.jsp" + _jspx_qStr, out, true);

it looks like a bug in tomcat 4.0.1, i didn't get these kind of error before (tomcat 3.2.4) i change to tomcat 4 because it supports request.setCharacterEncoding() method. so if you guys have the answer please let me know.

   <<Less
About | Sitemap | Contact