Tomcat is confused between sites
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   DC_Collins
Posted On:   Tuesday, March 18, 2008 09:31 AM

I have two "identical" jsp apps running on the same linux box. I've changed the connection info between both of them so that they run as separate sites. One site is called tema and the other is called tematest. They each have their own /home/ directory. Tema works fine, but tematest doesn't. I can get to the index.html page, but jsp is not doing anything. The page mentions a vague 500 error in IE but shows up blank in Firefox. Now, here's the catch. If I modify the /etc/tomcat5/server.xml file and "comment out" the tema site, tematest works fine. I am certain that dns/firewall information is correct. I'm also fairly certain the code is correct, but the app may be confusing Tomcat. Any ideas? Server version: Apache Tomca   More>>

I have two "identical" jsp apps running on the same linux box. I've changed the connection info between both of them so that they run as separate sites. One site is called tema and the other is called tematest. They each have their own /home/ directory. Tema works fine, but tematest doesn't. I can get to the index.html page, but jsp is not doing anything. The page mentions a vague 500 error in IE but shows up blank in Firefox. Now, here's the catch. If I modify the /etc/tomcat5/server.xml file and "comment out" the tema site, tematest works fine. I am certain that dns/firewall information is correct. I'm also fairly certain the code is correct, but the app may be confusing Tomcat. Any ideas?


Server version: Apache Tomcat/5.5.12

Server built: Dec 2 2005 02:50:01

Server number: 5.5.12.0

OS Name: Linux

OS Version: 2.6.9-22.ELsmp

Architecture: i386

JVM Version: 1.4.2_13-b06

JVM Vendor: Sun Microsystems Inc.

   <<Less
About | Sitemap | Contact