dcsimg
Servlet Calling Web Service: HTTP 500
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Aaron_Stephanus
Posted On:   Thursday, July 13, 2006 12:20 PM

I have a servlet that calls a Web Service that I've written. I receive an IOException that states that the server returned HTTP 500 when trying to access the input stream of the HttpURLConnection object opened against the web service. The method I am trying to call in my web service never gets called. Oddly enough, I can enter the URL of the service into my browser and it gets called. I'm using J2EE 1.4 with Tomcat 5.0.28. The SOAP request follows: <?xml version="1.0" encoding="utf-8"?> w.w3.org/2001/12/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-inst ance"> ="xsi:string"> aaron pas sword    More>>

I have a servlet that calls a Web Service that I've written. I receive an IOException that states that the server returned HTTP 500 when trying to access the input stream of the HttpURLConnection object opened against the web service.



The method I am trying to call in my web service never gets called. Oddly enough, I can enter the URL of the service into my browser and it gets called.



I'm using J2EE 1.4 with Tomcat 5.0.28.



The SOAP request follows:



			
<?xml version="1.0" encoding="utf-8"?>
w.w3.org/2001/12/soap-envelope" xmlns:xsi="http://www.w3.org/2001/XMLSchema-inst
ance">
="xsi:string"> aaron pas
sword



Can anyone help me through this. Any pointers, or questions that you can ask to help me in the right direction would be most appreciated. I've been around Google and have come up empty.


Thanks,


-Aaron

   <<Less
About | Sitemap | Contact