connectaddress for sys$routing listener?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   David_McCullough
Posted On:   Tuesday, March 7, 2006 10:48 PM

Hello, I'm evaluating SwiftMQ 5.2.6, and am running into a problem with a two broker network on Windows where the two machines are on different networks, and are apparently NATed. I couldn't get a simple JMS client to connect to either of the machines, but then I discovered the "connectaddress" attribute in the element under the sys$jms swiftlet. Setting this to the correct "outside" IP address worked. The problem I'm having now is that the brokers don't seem to be exchanging messages across the same topic. Could this be a problem due to NAT? Is there a similar "connectaddress" attribute for the element under the sys$routing swiftlet? I tried adding it, but it didn't    More>>

Hello,


I'm evaluating SwiftMQ 5.2.6, and am running into a problem with a two broker network on Windows where the two machines are on different networks, and are apparently NATed.


I couldn't get a simple JMS client to connect to either of the machines, but then I discovered the "connectaddress" attribute in the element under the sys$jms swiftlet. Setting this to the correct "outside" IP address worked.


The problem I'm having now is that the brokers don't seem to be exchanging messages across the same topic. Could this be a problem due to NAT? Is there a similar "connectaddress" attribute for the element under the sys$routing swiftlet? I tried adding it, but it didn't seem to have any effect.

Any ideas?

Thanks.

   <<Less

Re: connectaddress for sys$routing listener?

Posted By:   Andreas_Mueller  
Posted On:   Wednesday, March 8, 2006 03:05 AM

A "connectaddress" for the routing listeners are not necessary because there are no connection factories (that store this address) involved like in JMS. All you have to do is to use the "outside" address for your routing connector. It connects to your firewall that NATs it to your internal IP and the routing listener accepts it.


Of course, this implies that your other router is outside your firewall. You should use SwiftMQ Explorer to see whether the other router is connected or not.
About | Sitemap | Contact