JSSE compatible issue
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   saravanan_sridharan
Posted On:   Tuesday, January 10, 2006 01:00 PM

Hi We have SSL client certificate(verisign) for browser IE6 (that supports JDK 1.1.4) to access applet with AWT based application. My IBM server supports JDK1.3 Now we used Swing component in applet application, but IE6 browser does not support it. So I plugged java 1.4.2_06 into IE6. When I try to access applet with swing based application, I am getting the following error from browser java console. sun.plugin.cache.DownloadException at sun.plugin.cache.CachedFileLoader.load(Unknown Source) at sun.plugin.cache.FileCache.get(Unknown Source) at sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connectWithCache(Unknown    More>>

Hi


We have SSL client certificate(verisign) for browser IE6 (that supports JDK 1.1.4) to access applet with AWT based application. My IBM server supports JDK1.3





Now we used Swing component in applet application, but IE6 browser does not support it. So I plugged java 1.4.2_06 into IE6. When I try to access applet with swing based application, I am getting the following error from
browser java console.





sun.plugin.cache.DownloadException
at sun.plugin.cache.CachedFileLoader.load(Unknown Source)
at sun.plugin.cache.FileCache.get(Unknown Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connectWithCache(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.connect(Unknown
Source)
at
sun.net.www.protocol.https.PluginDelegateHttpsURLConnection.getInputStream(Unknown
Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
at
sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown
Source)
at sun.applet.AppletClassLoader.getBytes(Unknown Source)
at sun.applet.AppletClassLoader.access$100(Unknown Source)
at sun.applet.AppletClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at sun.applet.AppletClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.applet.AppletClassLoader.loadCode(Unknown Source)
at sun.applet.AppletPanel.createApplet(Unknown Source)
at sun.plugin.AppletViewer.createApplet(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)


Then, I unplugged JDK1.4.2_06 and system is started working fine when I plugged JDK 1.3.1_17.But requirement is to make the application run under JDK1.4 plug-in




Is it JSSE compatible issue with JDK1.4(that bundled with JSSE)?




Is it possible to upgrade with JDK1.4 with existing certificate?




Please assist me how to overcome this situation.




thanks in advance.




With regards


Saravanan

   <<Less
About | Sitemap | Contact