JMX with JRE 1.4
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Victor_Ho
Posted On:   Saturday, August 6, 2005 02:18 PM

Hi,


I understand that JMX in J2SE 1.5 has the VM instrumentation functionalities. Does anyone know if it can be supported in 1.4 also?


If not, can a custom MBean be created to do functionalities of the built-in VM instrumentation for running in JRE 1.4? Some examples would be great.


Thanks
Victor

Re: JMX with JRE 1.4

Posted By:   Anonymous  
Posted On:   Monday, August 8, 2005 09:26 AM

Tomcat 5.5 is developed for Java5 - for using under 1.4 you have to add the "1.5-compat.jar" which contains xml parser and a jmx.jar. I think that jar would be enough... Remind that JBoss has a JMX-based architecture and it´s older than Java5 ...
About | Sitemap | Contact