Doesn't generate servlet entry in web.xml anymore
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Michael_Brunner
Posted On:   Tuesday, May 18, 2004 03:13 AM

I have a servlet class with xdoclet tags inside. All went well until I moved the class to a new project. Since then, xdoclet generates the web.xml, but leaves the part. Other Information out of the servlet class are generated into the web.xml. I searched all, if i had an old path or something else, but I found nothing suspicious. Anyone an idea? Here my code snipplet: /** * Creation date: 13.04.2004 * @author Michael Brunner * @web.servlet name = "EchoServlet" * display-name = "Echo Servlet" * description = "Servlet bla bla" * * @web.servlet-mapping url-pattern = "/Echo" * * @web.ejb-ref name = &quo   More>>

I have a servlet class with xdoclet tags inside. All went well until I moved the class to a new project. Since then, xdoclet generates the web.xml, but leaves the part.
Other Information out of the servlet class are generated into the web.xml. I searched all, if i had an old path or something else, but I found nothing suspicious.
Anyone an idea?

Here my code snipplet:

			
/**
* Creation date: 13.04.2004
* @author Michael Brunner
* @web.servlet name = "EchoServlet"
* display-name = "Echo Servlet"
* description = "Servlet bla bla"
*
* @web.servlet-mapping url-pattern = "/Echo"
*
* @web.ejb-ref name = "ejb/Echo"
* type = "Session"
* home = "com...."
* remote = "com..."
* description = "Reference to the Echo EJB"
*
* @jboss.ejb-ref-jndi ref-name = "ejb/Echo"
* jndi-name = "ejb/mike/Echo"
*/
public class EchoServlet extends HttpServlet {
   <<Less

Re: Doesn't generate servlet entry in web.xml anymore

Posted By:   Michael_Brunner  
Posted On:   Tuesday, May 18, 2004 07:31 AM

I found the problem.
It was an mixup problem with the classpath. I took one jar of a set of jars from another location, than the rest.
After changing this, all went ok.
About | Sitemap | Contact