Poor handling of APPLET tags in NetScape 6.1 ?
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Srideep_Prasad
Posted On:   Thursday, May 6, 2004 10:45 AM

I have run into an irritating problem - apparently a bug in the Netscape 6.1 browser... Consider the following code... function Test1() { alert(" The applet's current width is:" + document.applets[0].width); document.applets[0].width=500; alert(" The applet should have been resized to 500 pixels width"); } ]]>]]> MAYSCRIPT name="app1" >   The applet is a dummy applet Now I load this page in IE 6...I click the document body, and IE correctly reports the applet width as 100, and resizes the applet width to 500 pixels... Now I load the page in NS 6.1...The p   More>>

I have run into an irritating problem - apparently a bug in the Netscape 6.1
browser...


Consider the following code...









MAYSCRIPT name="app1" >









 


The applet is a dummy applet


Now I load this page in IE 6...I click the document body, and IE correctly
reports the applet width as 100, and resizes the applet width to 500 pixels...


Now I load the page in NS 6.1...The page loads correctly...But when I click
the page, there is a slight delay, and then, the applet width is returned as
"undefined" by JavaScript no matter how I refer to the applet, or where I place
the script...


Also, if I select VIEW >> PREFERENCES >> UNCheck ENABLE JAVA and then reload
the Netscape browser, and then reload the page, the applet obviously does not
load, but the size is reported correctly as 100...Then without closing the
browser I reenable JAVA and then reload the page,the applet loads, the applet's
width is reported correctly as 100, and even resizes...But if I close the
browser, and then reload the page with JAVA "Pre-enabled" the "undefined"
problem crops up again...


I think this may be a serious bug in NS 6.1


I would like to know other opinions on this matter


Sincerely


Srideep Prasad

   <<Less
About | Sitemap | Contact