Why my XDoclet can't generate properly descriptor file?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   tongliang_lu
Posted On:   Friday, January 9, 2004 01:19 AM

Hi,I'm using XDoclet 2.1. I follows the basic rules of XDoclet tags and write some comments for XDoclet tags,it generate some files such as jboss.xml,ejb-jar.xml,jaws.xml.However it's only Big framework and comments ,like this: <![CDATA[No Description.]]> Generated by XDoclet the markup for those beans. --> the markup for those beans. --> the markup for those beans. --> the markup. -->    More>>

Hi,I'm using XDoclet 2.1.
I follows the basic rules of XDoclet tags and write some comments for XDoclet tags,it generate some files such as jboss.xml,ejb-jar.xml,jaws.xml.However it's only Big framework and comments ,like this:






<![CDATA[No Description.]]>


Generated by XDoclet








the markup for those beans.
-->





the markup for those beans.
-->






the markup for those beans.
-->
















the markup.
-->















I find its document and read it ,but I find out reasons why this case happends,
Can somebody enlight me and might help me figure out what Im doing wrong?



Regards
Lu    <<Less

Re: Why my XDoclet can't generate properly descriptor file?

Posted By:   Ching_Chew  
Posted On:   Sunday, January 11, 2004 07:20 PM

Hi Lu,

Would it be possible for you to post some of your xDoclet code?

The last time I had this problem, it was because I didn't place the xDoclet comments correctly. I found that it had to be:


/**
* all your xDoclet class tags
*/
public class MyClass {

}


cheers!

Ching

About | Sitemap | Contact