dcsimg
Linking Apache and Tomcat using mod_jk
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Ola_Tomoloju
Posted On:   Wednesday, October 8, 2003 04:11 AM

I have Tomcat 4.1.27 and Apache 2.0installed and working independently on a windows NTinstallation. I have followed a web resources in attempt to install mod_jk http://www.sitepoint.com/article/305/4 Success did not follow, but at least I am now getting error messages in $CATALINA_HOME/logs/mod_jk.log [Wed Oct 08 10:11:28 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61 [Wed Oct 08 10:11:28 2003] [jk_ajp_common.c (626)]: Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61 [Wed Oct 08 10:11:30 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61 [Wed Oct 08 10:11:30 2003] [jk_   More>>

I have Tomcat 4.1.27 and Apache 2.0installed and
working independently on a windows NTinstallation. I have followed
a web resources in attempt to install mod_jk
http://www.sitepoint.com/article/305/4


Success did not follow, but at least I am now getting error messages
in $CATALINA_HOME/logs/mod_jk.log

[Wed Oct 08 10:11:28 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61
[Wed Oct 08 10:11:28 2003] [jk_ajp_common.c (626)]: Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61
[Wed Oct 08 10:11:30 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61
[Wed Oct 08 10:11:30 2003] [jk_ajp_common.c (626)]: Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61
[Wed Oct 08 10:11:32 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61
[Wed Oct 08 10:11:32 2003] [jk_ajp_common.c (626)]: Error connecting to tomcat. Tomcat is probably not started or is listenning on the wrong port. Failed errno = 61
[Wed Oct 08 10:11:34 2003] [jk_connect.c (203)]: jk_open_socket, connect() failed errno = 61


Of course Tomcat is started - but if it's listening on the right ports
or not is not clear to me.

Please Help

.

   <<Less

Re: Linking Apache and Tomcat using mod_jk

Posted By:   Anonymous  
Posted On:   Wednesday, October 8, 2003 10:27 AM

Hi

you may want to use the jk2 connector, at least thats what this book I have tells me. I had a tough time getting those 2 to talk but I figured it out. Also I have found a site that goes through the whole process its at

http://www.greenfieldresearch.ca/technical/jk2_config.html


look at that and hopefully it will help, as the book I bought sure didn't :).


Evan Brown
About | Sitemap | Contact