AppServer Authentication causing problem with Web Services
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   m_k
Posted On:   Monday, August 18, 2003 02:23 PM

I am currently using IBM WebSphere Studio 5 for developing a Web based application. The User Profile is stored in LDAP and works perfectly well when securing Web Pages. The AppServer automatically Authenticates every User using j-security_check Servlet. Now the same application has a SOAP Interface also. It takes the Input as a SOAP Attachment. Using SAAJ earlier when no Security was in place everything worked fine but after enabling the Security the test client code gets Previlige error. Unfortunately the "SOAPConnection" class supports no property that allows the user to pass in the UserId as well as Password. I started experimenting with SOAPHttpConnection class as well as Call class to package all the credentials but did not hav   More>>




I am currently using IBM WebSphere Studio 5 for developing a Web based application.
The User Profile is stored in LDAP and works perfectly well when securing Web Pages. The AppServer automatically Authenticates every User using j-security_check Servlet. Now the same application has a SOAP Interface also. It takes the Input as a SOAP Attachment. Using SAAJ earlier when no Security was in place everything worked fine but after enabling the Security the test client code gets Previlige error. Unfortunately the "SOAPConnection" class supports no property that allows the user to pass in the UserId as well as Password. I started experimenting with SOAPHttpConnection class as well as Call class to package all the credentials but did not have much success. I would appreciate if any one can make some sort of comments here to help me out with this scenario.


Thanks.

   <<Less
About | Sitemap | Contact