MIDP 2.0 games.* package on MIDP 1.0 app?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Harald_Freund
Posted On:   Tuesday, July 29, 2003 07:48 AM

Is it possible to create a MIDP 1.0 MIDlet and still using the games.* package of the MIDP 2.0 by including the needed classes in the jar file? It is possible to compile such a program, but I couldn't figure out a way to run it. I got error messages like "native method ... not found".

I guess I have to create my own games library, but I was wondering if there's any way to avoid this.

Any ideas?

Thanks in advance

Re: MIDP 2.0 games.* package on MIDP 1.0 app?

Posted By:   Jason_Lam  
Posted On:   Saturday, September 6, 2003 10:51 AM

Should be no problem, as long as the game classes aren't dependant on other classes outside the game package. Then of course you will need to include those as well.

Keep mind your totally jar file size will increase, considering the MIDP 1.0 by default doesn't include these.

As well some MIDP 1.0 phone may or may not have the processing power to do such things a TiledLayer scrolling.

Just my initial thoughts on this, I personally haven't had the chance to try this out myself, but it did cross my mind.

Can you please tell me if this worked for you?

fyi, some Free J2ME & Gaming chapters at

http://www.jasonlam604.com remaining chapters will be released when complete
About | Sitemap | Contact