Related to Custom Realm in weblogic6.1
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Raghs_J
Posted On:   Monday, January 27, 2003 09:20 AM

Hi , I have my custom realm defined in weblogic6.1. and the TTL i have specified is 86400 for users,groups,permissions etc, I have my own custom realm which extends AbstractListableRealm Actually am connecting to LDPA server whis is on different machine. I have defined all my groups in web.xml file An am using form based authentication using j_security_check When I login every day for the first time..I get error 500 and the stack trace on the consol is ================================================== java.lang.RuntimeException: unexpected error - group "Brokers" does not exist at weblogic.security.acl.FlatGroup.fillCache(FlatGroup.java:176) at we   More>>

Hi ,
I have my custom realm defined in weblogic6.1.
and the TTL i have specified is 86400 for users,groups,permissions etc,

I have my own custom realm which extends AbstractListableRealm
Actually am connecting to LDPA server whis is on different machine.

I have defined all my groups in web.xml file
An am using form based authentication using j_security_check

When I login every day for the first time..I get error 500 and the stack trace on the consol is

==================================================
java.lang.RuntimeException: unexpected error - group "Brokers" does not exist
at weblogic.security.acl.FlatGroup.fillCache(FlatGroup.java:176)
at weblogic.security.acl.FlatGroup.ensureFreshness(FlatGroup.java:170)
at weblogic.security.acl.FlatGroup.isMember(FlatGroup.java:217)
at com.nextlinx.png.security.SSOWebCustomRealmGroup.isMember(SSOWebCustomRealmGroup.java:69)

at weblogic.servlet.security.internal.WebAppSecurity.isPrincipalInRole(WebAppSecurity.java:3
02)
at weblogic.servlet.security.internal.WebAppSecurity.hasPermission(WebAppSecurity.java:219)
at weblogic.servlet.security.internal.SecurityModule.checkPerm(SecurityModule.java:92)
at weblogic.servlet.security.internal.FormSecurityModule.checkUserPerm(FormSecurityModule.ja
va:338)
at weblogic.servlet.security.internal.SecurityModule.beginCheck(SecurityModule.java:136)
at weblogic.servlet.security.internal.FormSecurityModule.checkA(FormSecurityModule.java:169)

at weblogic.servlet.security.internal.ServletSecurityManager.checkAccess(ServletSecurityMana
ger.java:172)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:25
18)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2260)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
>
=================================================
But when I login again ...everything will be alright.

I want to know Y it gives error when I login for first time everyday.

I descreased the TTL to 3600 and I get the same error every hour.

Is there any settings am missing , if not what is the solution to get rid of this problem

Your response is highly appreciated.

If you need any additional info..pls lemme know

   <<Less
About | Sitemap | Contact