IntelliJ remote debugging does not work
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Java_Guru
Posted On:   Sunday, July 9, 2006 05:44 PM

We are using IntelliJ 5.1.1 to develop a client server application. The server app is running under JBoss 4.0.2. The client is an SWT app.


We are having problems getting remote debug to work. On my machine it does not work at all (stopping on breakpoints) and on others machines it will only work intermittently.


We have tried all of the obvious things but it still does not work. This is creating significant delays during development.


Any ideas?

Re: IntelliJ remote debugging does not work

Posted By:   rehnesh_k  
Posted On:   Tuesday, August 29, 2006 06:49 AM

Probably your code getting some problms
Check your code

Re: IntelliJ remote debugging does not work

Posted By:   rehnesh_k  
Posted On:   Tuesday, August 29, 2006 06:48 AM

At first you have to the server on Debug mode
After that you have to listen the same port at server starts

Re: IntelliJ remote debugging does not work

Posted By:   WarnerJan_Veldhuis  
Posted On:   Monday, July 10, 2006 03:12 AM

I use IntelliJ as well, but I have never had these kinds of problems. Make sure the %JAVA_OPTS% is not overwritten in batchfiles. Also make sure when appending to the JAVA_OPTS variable, that you do a += kinda operation:

set JAVA_OPTS=-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005
set JAVA_OPTS=%JAVA_OPTS% more opts here
^^^^^^^^^^^
About | Sitemap | Contact