"User database not loaded" error - Struts 1.0.2 Example Application
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   David_Howie
Posted On:   Monday, August 26, 2002 03:19 PM

I installed the struts source code (1.0.2) and struts example source in VAJ 3.5.3. I configured Websphere Test Environment to run the example app. When I go to the index.jsp I get the message "User database not loaded". If I go to the logon.jsp and try to log on using the user/password from the database.xml file, I get "User database is missing, cannot validate logon credential". From reviewing the source code I see that the init() method of org.apache.struts.webapp.example.DatabaseServlet needs to be called to initialize the (psuedo) database, however, the init() method is not being called and I cannot figure out why. Any help would be greatly appreciated. Thanks Dave    More>>

I installed the struts source code (1.0.2) and struts example source in VAJ 3.5.3. I configured Websphere Test Environment to run the example app.


When I go to the index.jsp I get the message "User database not loaded". If I go to the logon.jsp and try to log on using the user/password from the database.xml file, I get "User database is missing, cannot validate logon credential".

From reviewing the source code I see that the init() method of org.apache.struts.webapp.example.DatabaseServlet needs to be called to initialize the (psuedo) database, however, the init() method is not being called and I cannot figure out why.


Any help would be greatly appreciated.


Thanks
Dave

   <<Less

Re: "User database not loaded" error - Struts 1.0.2 Example Application

Posted By:   David_Howie  
Posted On:   Monday, August 26, 2002 03:43 PM

Ignore my previous question. I realized I needed to configure my webapp to also load the DatabaseServlet upon startup of the container (Websphere Test Environment).

Thanks

About | Sitemap | Contact