Remote Class loading problems
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Tim_Rickard
Posted On:   Wednesday, July 24, 2002 07:28 AM

I cant get class files to load remotely. I am doing the sun tutorial and everything is fine until I try remote loading. I have tried setting the codebase using both file and http.
When I enter the url in IE from the client I can see the directory on the server but when I run the client remotely I get ClassNotFoundException engine.ComputeEngine_Stub. I am obviously doing something dumb but I cant see it. Any suggestions on something to try.

Re: Remote Class loading problems

Posted By:   Sanjeev_Kasarabada  
Posted On:   Friday, July 26, 2002 10:53 AM

Hi,



I faced the same kind of problem recently. If u are still facing this problem I am sure it has to with the Stub class.
When u run the RemoteServer I mean the Impl class using the java -D option make sure it like this



java -classpath C:src;C:classes -Djava.rmi.server.codebase=C:classes


The C:webrootclasses should contain both the The REmote class and the RMI generated stub and skeletons.



Make sure the stubs and skeletons exist in the codebase property. Hope it helps.


Sanjeev

About | Sitemap | Contact