Problem with converter
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   martins_georges
Posted On:   Monday, May 27, 2002 10:16 AM

Hello, I have a problem with Converter of the Javacard kit 2.1.2. I have a package with 2 applets inside (AppletPIN and AppletAdmin) and an interface. I already generated all my .CLASS files, but when I try to generate the .CAP file, the Converter returns the error: “Invalid AppletPIN AID”. Here is the command line I use: converter -applet 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x01 AppletAdmin 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x02 AppletPin -classdir E:JavaCardkitjava_card_kit-2_1_2samplessrc com.sun.javacard.samples.AppliPackage 0xA0:0x00:0x00:0x00:0x62:0x05:0x03 1.0 I also tried this one: converter -applet 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x01 AppletAdm   More>>


Hello,


I have a problem with Converter of the Javacard kit 2.1.2.


I have a package with 2 applets inside (AppletPIN and AppletAdmin) and an interface. I already generated all my .CLASS files, but when I try to generate the .CAP file, the Converter returns the error: “Invalid AppletPIN AID”. Here is the command line I use:


converter -applet 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x01 AppletAdmin 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x02 AppletPin -classdir E:JavaCardkitjava_card_kit-2_1_2samplessrc com.sun.javacard.samples.AppliPackage 0xA0:0x00:0x00:0x00:0x62:0x05:0x03 1.0


I also tried this one:


converter -applet 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x01 AppletAdmin 0xA0:0x00:0x00:0x00:0x62:0x05:0x03:0x02:0x01 AppletPin -classdir E:JavaCardkitjava_card_kit-2_1_2samplessrc com.sun.javacard.samples.AppliPackage 0xA0:0x00:0x00:0x00:0x62:0x05:0x03 1.0


But I get the same error.


Finally, if I don’t set an AID for the AppletAdmin, it works perfectly … except that I can’t instantiate an Applet that doesn’t have a default AID!!
If anybody knows the right command line to type, I’d be glad to read it. Thanks by advance for any help.


Georges Martins

   <<Less

Re: Problem with converter

Posted By:   Joseph_Smith  
Posted On:   Tuesday, May 28, 2002 12:46 PM

if you are using multiple applets, you'll need the -applet for each
About | Sitemap | Contact