question about chinese charactor
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   zhebin_cong
Posted On:   Saturday, May 25, 2002 03:19 AM

hello i use jbuilder6 bind struts to develop the program,in the program,there is a text box,that is used to input the user name,because i want to input chinese charactor to the box,i use following code snippet in the action class to encode the input charactor: EmployeeForm empForm=(EmployeeForm)form; String name=empForm.getName(); byte[] temp=name.getBytes("ISO8859_1"); name=new String(temp); empForm.setName(name); after i click the submit button,the name will display in the next page,when i start the tomcat built in jbuilder6,test the program within the jbuilder6 window,it works well,but at same time,i open a ie explorer,debug it in the ie,the chinese charactor can't display    More>>

hello


i use jbuilder6 bind struts to develop the program,in the program,there is a text box,that is used to input the user name,because i want to input chinese charactor to the box,i use following code snippet in the action class to encode the input charactor:


EmployeeForm empForm=(EmployeeForm)form;
String name=empForm.getName();
byte[] temp=name.getBytes("ISO8859_1");
name=new String(temp);
empForm.setName(name);

after i click the submit button,the name will display in the next page,when i start the tomcat built in jbuilder6,test the program within the jbuilder6 window,it works well,but at same time,i open a ie explorer,debug it in the ie,the chinese charactor can't display correctly,i am sure the ie encoding setting is correct.

who can help me?

thank you

   <<Less
About | Sitemap | Contact