dcsimg
How do i disable output escaping?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Michael_Aird
Posted On:   Tuesday, May 21, 2002 02:17 PM

What I'm doing is reading an xhtml file in and parsing it as an XML document. Then i add various nodes to it in the and area. I'm writing it back out using a StreamResult. I need to turn output escaping off because what i'm adding into the may contain some HTML. Can anybody tell me how I can do this?

Thanks,
Michael.

Re: How do i disable output escaping?

Posted By:   irfan_mansha  
Posted On:   Thursday, May 23, 2002 01:41 AM

I think this is a great problem with dom. U have to handle this manually using coding. There is another way to avoid escaping is that use dtd or xml shema to validate ur xhtml docment. In this case parser come to know that which is required information. It gives u information of that structure which u have defined in dtd or xml schema. I think that this is only straight way to do this.



if u don't use any shema for validation then parser takes white spaces and escaping as nodes.




I think it would be helpful for u.



Take care,


Irfan Mansha.
About | Sitemap | Contact