dcsimg
Websphere 4 Admin Server Problem
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Kapil_Gupta
Posted On:   Saturday, May 11, 2002 12:22 AM

I have installed WAS 4 on Windows NT Workstation with Oracle DB on separate machine. When I try to start the Admin Server it gives specific error 10 and the log file says "Could not Load Database Driver".

I have checked the admin file and it shows the correct path of the oracle driver(classes12.zip and nls_charset12.zip files)
If I install WAS on same machine on which oracle is installed, then admin server starts successfully but I am not able to open the console window.

Can somebody tell me where i can find guide for installing WAS 4 with Oracle on separate machine?

Best Regards,
Kapil

Re: Websphere 4 Admin Server Problem

Posted By:   Rosemarie_Leighton  
Posted On:   Wednesday, May 15, 2002 12:06 AM

hi Kapil
I am not sure as I am new in this industry, all I know from past experience is that the location of the driver must be in the classpath and I just put the classes111.zip in in there to ensure that I had covered all bases.

Re: Websphere 4 Admin Server Problem

Posted By:   Rosemarie_Leighton  
Posted On:   Tuesday, May 14, 2002 10:22 PM

Hi

I have just had the same error, I have to connect to a remote database as well as a local and it worked for both. Check that you have the classes.zip file in your classpath on your system. Also download the following tool : jdbctest tool from ibm -
ftp://ftp.software.ibm.com/software/websphere/info/tools/jdbctest (can be slow as it is a ftp site). Info about this product can be found on the following url : http://www-3.ibm.com/software/webservers/appserv/doc/tools/jsread2.html. This tool checks the connection between websphere and oracle/db2.
Hope you come right :)

Re: Websphere 4 Admin Server Problem

Posted By:   Laurent_Mihalkovic  
Posted On:   Saturday, May 11, 2002 02:25 PM

does your jdbc driver work with a normal simple standalone test application? If you get the same problem, then you know that the problem is with the driver, and most likely that you have to install the ORACLE Client on your WAS machine, so that the proper oracle CLI libraries are there.

if it does, then you know that you have some sort of path configuration problem with the way you launch WAS.

hope that helps
laurent

About | Sitemap | Contact