Does ANT 1.3 Support Compilation of EJB1.1 s for Weblogic 6.1
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Seshadri_Kasi
Posted On:   Sunday, May 5, 2002 11:40 PM

I am Using ANT 1.3 and Weblogic 6.1, When I try to compile EJBs I am getting this Exception.. D:srcesupport oolsant uild.xml:1267: SAXException while parsing 'ejb-jar.xml'. This probably indicates badly-formed XML. Details: External entity not found: "http://java.sun.com/dtd/ejb-jar_1_1.dtd". --- Nested Exception --- java.net.SocketException: no further information (code=10071) at com.sun.xml.parser.Parser.fatal(Parser.java:2817) at com.sun.xml.parser.Parser.externalParameterEntity(Parser.java:2506) at com.sun.xml.parser.Parser.maybeDoctypeDecl(Parser.java:1137) at com.sun.xml.parser.Parser.parseInternal(Parser.java:481) at com.sun.xml.parser.Parser.parse(Parser.java   More>>

I am Using ANT 1.3 and Weblogic 6.1, When I try to compile EJBs I am getting this Exception..





D:srcesupport oolsant uild.xml:1267: SAXException while parsing 'ejb-jar.xml'. This probably indicates badly-formed XML. Details: External entity not found: "http://java.sun.com/dtd/ejb-jar_1_1.dtd".
--- Nested Exception ---
java.net.SocketException: no further information (code=10071)
at com.sun.xml.parser.Parser.fatal(Parser.java:2817)
at com.sun.xml.parser.Parser.externalParameterEntity(Parser.java:2506)
at com.sun.xml.parser.Parser.maybeDoctypeDecl(Parser.java:1137)
at com.sun.xml.parser.Parser.parseInternal(Parser.java:481)
at com.sun.xml.parser.Parser.parse(Parser.java:284)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:155)
at org.apache.tools.ant.taskdefs.optional.ejb.GenericDeploymentTool.processDescriptor(GenericDeploymentTool.java:287)
at org.apache.tools.ant.taskdefs.optional.ejb.EjbJar.execute(EjbJar.java:413)
at org.apache.tools.ant.Target.execute(Target.java:153)
at org.apache.tools.ant.Project.runTarget(Project.java:898)






BEA news Group I read that I need to have Webligoc.jar in the class path to fetch the DTD file . So I have set the same.




But Still I am getting this Exception
Can any one help me..


Thanks
Seshadri

   <<Less

Re: Does ANT 1.3 Support Compilation of EJB1.1 s for Weblogic 6.1

Posted By:   Erik_Hatcher  
Posted On:   Monday, May 6, 2002 03:01 AM

Your best bet is to upgrade to Ant 1.5Beta1 if at all possible. I won't be supporting Ant 1.3 here.
About | Sitemap | Contact