dcsimg
Library path and Tomcat
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Gaelle_SMITS
Posted On:   Thursday, May 2, 2002 02:51 AM

Hello ! I have a problem of library with using JNIs and Tomcat. (tomcat 3.3.1, jdk 1.2.2) I have programmed with JNI, and created a .so library that seems not to be found : I get this error message : Java.lang.UnsatisfiedLinkError : no CsimSimple in java.library.path Im my Java class, I used : System.loadLibrary(« CsimSimple ») ; (I tried with load and the full path of the library, but didn’t get more success) I set the environnement variable LD_LIBRARY_PATH to the path of my .so library. Does anybody have an idea of why it won’t work ? It’s probably a problem of library path. Is there a special place my .so library ought to be ? What shou   More>>

Hello !

I have a problem of library with using JNIs and Tomcat. (tomcat 3.3.1, jdk 1.2.2)

I have programmed with JNI, and created a .so library that seems not to be found : I get this error message :
Java.lang.UnsatisfiedLinkError : no CsimSimple in java.library.path

Im my Java class, I used : System.loadLibrary(« CsimSimple ») ; (I tried with load and the full path of the library, but didn’t get more success)

I set the environnement variable LD_LIBRARY_PATH to the path of my .so library.

Does anybody have an idea of why it won’t work ?

It’s probably a problem of library path.

Is there a special place my .so library ought to be ?

What should I set my LD_LIBRARY_PATH variable to, since it doesn’t seem to be correct ?

Is my call to the loadLibrary correct ?

Any answer will be welcome !

Gaelle.

   <<Less

Re: Library path and Tomcat

Posted By:   laurent_drouet  
Posted On:   Wednesday, May 8, 2002 09:45 AM

Hello,

I have a similar problem...

First I have programmed an application running with a library in C with JNI.
The only way the program works was putting this library in the path where
i lauch the application. All my tries with LD_LIBRARY_PATH didn't success,
in order to have a better place for the library.
The problem now is that i use a part of my code with servlets and tomcat. i use
the class which call my library. But now it doesn't work and i don't now
where to put the library...

Thanks for your help

Laurent
About | Sitemap | Contact