Running an Entity EJB (BMP) on Websphere 4.0 and Oracle
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   CHOLLET_LOL
Posted On:   Sunday, April 28, 2002 01:32 PM

I use Websphere Application Studio 4.0 and Oracle 8.1.7 I'm trying to test an EJB Entity BMP and I get errors related to Oracle URL. java.sql.SQLException:Wrong URL Oracle:OracleDataSource.makeURL I've configured the server with the appropriate JDBC class located in classes12.zip:oracle.jdbc.pool.OracleConnectionPoolDataSource I've also created a DataSource related to this Driver. But my EJB won't connect correctly to the Database and I don't know why. It finds correctly the DataSource but is unable to use the getConnection() method from the DS. Does anyone know how to use DataSource in Websphere with Oracle ?    More>>

I use Websphere Application Studio 4.0 and Oracle 8.1.7


I'm trying to test an EJB Entity BMP and I get errors related to Oracle URL.

java.sql.SQLException:Wrong URL
Oracle:OracleDataSource.makeURL



I've configured the server with the appropriate JDBC class located in classes12.zip:oracle.jdbc.pool.OracleConnectionPoolDataSource

I've also created a DataSource related to this Driver.


But my EJB won't connect correctly to the Database and I don't know why.

It finds correctly the DataSource but is unable to use the getConnection() method from the DS.



Does anyone know how to use DataSource in Websphere with Oracle ?


Thanks a lot.


Lorent.

   <<Less

Re: Running an Entity EJB (BMP) on Websphere 4.0 and Oracle

Posted By:   janardhanan_rukmangathan  
Posted On:   Sunday, June 9, 2002 11:39 PM

I just went through the trauma of configuring WebSphere 4.0 datasources using Oracle . I know what your problem is

But can you send the configuration parameters that you've used . I can correct them for you.
About | Sitemap | Contact