RMI and Corba
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   jun_li
Posted On:   Thursday, April 18, 2002 01:35 PM

I have a very simple RMI solution here: an applet call the rmi server to access one method to send some data to the backend. We also have visibroker agent running in the same env. If I start rmiregistry and rmi server first, everything is OK. If I do otherwise, I will get the following error: Error: java.rmi.ServerException: RemoteException occurred in server thread; nested exception is: java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is: java.lang.ClassNotFoundException: PublishImpl_Stub I have that stub class in the same folder of server class and in classpath. My applet alos acts strange. The first time I start it, everything is fine. If I keep using it without restart the session, I still   More>>

I have a very simple RMI solution here: an applet call the rmi server to access one method to send some data to the backend. We also have visibroker agent running in the same env. If I start rmiregistry and rmi server first, everything is OK. If I do otherwise, I will get the following error:
Error: java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
java.lang.ClassNotFoundException: PublishImpl_Stub
I have that stub class in the same folder of server class and in classpath.

My applet alos acts strange. The first time I start it, everything is fine. If I keep using it without restart the session, I still get the success message back from the server side, but actually the server does nothing.

Jun

   <<Less
About | Sitemap | Contact