Visibroker 4.0 with jdk 1.4?
0 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   bowlong_chang
Posted On:   Saturday, April 13, 2002 04:59 AM

How can I connect vbroker 4.0 to jdk1.4? If I set my classpath=e:vcafejavalibclasses.zip and type vbj -VBJversion.It will print: VisiBroker Developer for Java [04.00.01.C1.13] (NOV 30 1999 18:53:34) Java: Version 1.1.3 from Sun Microsystems Inc. OS: Windows NT version 5.0; CPU: x86 But the version in e:vcafejavalibclasses.zip is 1.1.7 but not 1.1.3.I can't understand why it is from Sun Microsystems.It should have be form "Webgain" where the classpath is set. And on my classmate's computer it do. I can find where the version from Sun on all of my computer too. And if I didn't set the classpath=d:jdk14lib,it just printed: Unabl   More>>

How can I connect vbroker 4.0 to jdk1.4?


If I set my classpath=e:vcafejavalibclasses.zip and type
vbj -VBJversion.It will print:

VisiBroker Developer for Java [04.00.01.C1.13] (NOV 30 1999 18:53:34)

Java: Version 1.1.3 from Sun Microsystems Inc.

OS: Windows NT version 5.0; CPU: x86


But the version in e:vcafejavalibclasses.zip is 1.1.7 but not 1.1.3.I can't understand why it is from Sun Microsystems.It should have be form "Webgain" where the classpath is set. And on my classmate's computer it do.
I can find where the version from Sun on all of my computer too.


And if I didn't set the classpath=d:jdk14lib,it just printed:


Unable to initialize threads: cannot find class
java/lang/Thread

could not create JVM



It meant that the vbroker couldn't find the VM.

So how should I do if I want to conenct my vbroker with jdk1.4?

Thanks a lot.

   <<Less
About | Sitemap | Contact