Integrating JDK1.4.0 with JB6?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anonymous
Posted On:   Tuesday, April 9, 2002 10:59 PM

Have anyone tried integrating JDK1.4.0 into JB6 yet? Will it work or we've to wait for the next release of JB?

Re: Integrating JDK1.4.0 with JB6?

Posted By:   Laurent_Mihalkovic  
Posted On:   Wednesday, April 10, 2002 12:14 AM

"integration" ?? Do you mean using jbuilder with 1.3.3 and adding 1.4 to the list of target jdk or running jbuilder itself with 1.4?


Neither is supported by borland. The official "non-official answer" is that you should wait until the next release. Several reasons for that:


  • there are some pretty nasty bugs involving running 1.3.1 to debug a 1.4 VM, as well as some incompatibilities between the jpda implementations. One guy at borland was saying officially 'non-officially' that they are nasty enough to warrant waiting until Sun fixe them.
  • running jbuilder 6 over 1.4 also has its share of problems. In particular, the new focus manager architecture will force borland to recode all the wizards.

All is not that grin, though. I have been using jb6 over 1.4 since january for server side development. Except for the odd (read annoying) problem with some of the dialog boxes, I am totally satisfied. The speed and L&F improvements are well worth the minor troubles.

hope that helps
laurent

About | Sitemap | Contact