Integration Tomcat4.0.3, webapp-module1.0-tc40, and Apache 1.3.19
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   jeff_tate
Posted On:   Wednesday, March 20, 2002 10:14 AM

My config RH Linux 7.1 (2.4.3-12) httpd.conf ... # Tomcat Warp Connector LoadModule webapp_module modules/mod_webapp.so ... # Tomcat Warp Connector AddModule mod_webapp.c ... ServerName taz ... # Tomcat-Apache (Jakarta) Connector Settings # using mod_webapp.so (Loaded and Added Earlier) WebAppConnection WarpConnection warp taz:8008 WebAppDeploy examples WarpConnection /examples With this configuration, my apache web server fails to start. Error message: Syntax error on line 780 of /etc/httpd/conf/ht   More>>

My config


RH Linux 7.1 (2.4.3-12)


httpd.conf

...

# Tomcat Warp Connector

LoadModule webapp_module modules/mod_webapp.so

...

# Tomcat Warp Connector

AddModule mod_webapp.c

...

ServerName taz

...

# Tomcat-Apache (Jakarta) Connector Settings

# using mod_webapp.so (Loaded and Added Earlier)

WebAppConnection WarpConnection warp taz:8008

WebAppDeploy examples WarpConnection /examples




With this configuration, my apache web server fails to start. Error message:


Syntax error on line 780 of /etc/httpd/conf/httpd.conf:
Invalid port number (p <1) No "Port" statement found


line 780 is my "WebAppDeploy" Line



Anybody have any suggestions about this "Port" statement that apache (or webapp_module) is looking for?



The Warp connector section in my server.xml is unmodified from tomcat4.0.3 default install.


Thanks for the help

   <<Less

Re: Integration Tomcat4.0.3, webapp-module1.0-tc40, and Apache 1.3.19

Posted By:   Thierry_Schembri  
Posted On:   Thursday, March 21, 2002 08:28 AM

Add this somewhere in your httpd.conf :


Port 80



It should work
About | Sitemap | Contact