How do I set the library path with VAJ 4.0?
1 posts in topic
Flat View  Flat View

Posted By:   Anonymous
Posted On:   Sunday, March 17, 2002 11:03 AM

I need to add a directory to the Java libary path to address "UnsatisfiedLinkError" problems. I know what the directory is, but where in VAJ 4 do I add that directory? And to what -- class, or project or where?

Re: How do I set the library path with VAJ 4.0?

Posted By:   Anonymous  
Posted On:   Monday, March 18, 2002 02:06 PM

Answering my own question. The library path is set, as the documentation implies, by setting the path in environment of the operating system (Windows 2000 in this case). But VisualAge Java has a problem with long paths. If your path is too long, VAJ will simple ignore the previously set path and put only itself in the path.

One answer is to shorten your path variable. A workaround is create a small bat file that creates a minumum path (only those elements required to run in the VAJ environment). Put that in the Program sub-directory of the IDE. End the bat file by calling IVJENV.bat (which starts the IDE) and change the VAJ shortcut to point to your new bat file.
About | Sitemap | Contact