dcsimg
Problem in accessing MQ Series using the new JMS Provider setup in IBM Websphere Application Server 4.0
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Devadasan_Robinson
Posted On:   Friday, March 15, 2002 11:42 PM

I am migrating a web application from IBM Web App 3.5 to 4.0. I have problem in accessing MQ Series using the JMS Provider setup in IBM Web App 4.0 MY present set up: ================== Windows 2000 Prof Edtion IBM Websphere AppServer 4.0 (Advanced Single Server Edition) IBM HTTP Server 1.3.19 MQ Series 5.2 JMSProvider of WebSphere 4.0 used to configure JMS. 1. I am not able to retrieve WSQueueConnectionFactory and MY_Q_1 in the JNDI. The error I got is: [02.03.13 19:13:15:571 GMT+05] 6a2caab4 Helpers W NMSV0605E: A Reference object looked up from the context "domainRoots/UnspecifiedDom   More>>

I am migrating a web application from IBM Web App 3.5 to 4.0.

I have problem in accessing MQ Series using the JMS Provider setup in IBM Web App 4.0


MY present set up:

==================

Windows 2000 Prof Edtion
IBM Websphere AppServer 4.0 (Advanced Single Server Edition)

IBM HTTP Server 1.3.19

MQ Series 5.2

JMSProvider of WebSphere 4.0 used to configure JMS.






1.
I am not able to retrieve WSQueueConnectionFactory and MY_Q_1 in the JNDI.

The error I got is:
[02.03.13 19:13:15:571 GMT+05] 6a2caab4 Helpers W NMSV0605E: A Reference object looked up from the context "domainRoots/UnspecifiedDomainName/legacyRoot" with the name "jms/WSQueueConnectionFactory" was sent to the JNDI Naming Manager and an exception resulted.
Reference data follows:
Reference Factory Class Name: com.ibm.ws.naming.util.IndirectJndiLookupObjectFactory
Reference Factory Class Location URLs:
Reference Class Name: java.lang.Object
Type: JndiLookupInfo
Content: com.ibm.ws.naming.util.JndiLookupInfo@9b0eaae


Exception data follows:
javax.naming.NameNotFoundException: WSQueueConnectionFactory



2.

If I use JMSAdmin to configure JMS as I used to do in WAS 3.5, it is working fine.

But When I restart the WAS 4.0, all my entries are lost. That is, whatever I have configured using JMSAdmin tool is lost.



Could anybody help me in solving these issue.



thanks and regards,

D Robinson

   <<Less

Re: Problem in accessing MQ Series using the new JMS Provider setup in IBM Websphere Application Server 4.0

Posted By:   jdev3000_jdev3000  
Posted On:   Tuesday, March 26, 2002 03:13 AM

Hi Devadasan


I also faced similar issues when migrating from WAS 3.5 to WAS 4.0.



Did you declare the JMS Provider and all the JMS resources (connection factories, topics ...) with Websphere admin panel ?



Did you use the Websphere Admin panel to make a binding between the declared resources to the ones you have created with JMSAdmin ?



NB : The resources you declare under Websphere are created under the context jms !



If you have made all these things, let me know.

In that case, can you please me more detail on what you have already done.



Regards,

Aboubacar.
About | Sitemap | Contact