Compatibility shared repository VAJ 3.5 and 4.0
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Claudio_Barca
Posted On:   Tuesday, February 19, 2002 01:36 AM

Do you have notice of problems in development with VAJ 3.5 and 4.0 together in the same shared repository ?


Thank's

Re: Compatibility shared repository VAJ 3.5 and 4.0

Posted By:   daniel_walker  
Posted On:   Wednesday, February 20, 2002 08:41 PM

I agree with Eric. I've just started using VAJ 4.0, the rest of my team are using VAJ 3.5.3 and we're having no problems. Ensure you're running version 7.1 of EMSRV as recommended in the VAJ 4.0 documentation.

Re: Compatibility shared repository VAJ 3.5 and 4.0

Posted By:   Eric_Rizzo  
Posted On:   Tuesday, February 19, 2002 08:52 PM

No, should be no problem at all. The repository and server (EMSRV) were designed to handle different versions of whatever is put into them. In fact, the repository is not even specific to Java code - it can be (and is) used to store almost any arbitrary artifact. I've even heard of the same repository/EMSRV handling both VA Java and VA Smalltalk code at the same time.

As long as all the VAJ instances that connect to the repos server can find the versions of all the Projects they need, it should be fine.
About | Sitemap | Contact