Running under Java 1.4
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anthony_Pereira
Posted On:   Wednesday, February 13, 2002 03:20 PM

I am having trouble running SwiftMQ under java 1.4 beta-3. Even though I am able to start my routers (in examples provided), when I try to connect to them I get a "Connection lost" message. On checking the logs for the routers, I see that there was a socket timeout exception when the connection was attempted. This happens with both the CLI and Explorer.


Has anyone else encountered this problem?


Any comments/suggestions would be grateful.


Many Thanks
Anthony.

Re: Running under Java 1.4

Posted By:   Andreas_Mueller  
Posted On:   Thursday, February 14, 2002 01:29 AM

I've just checked that. There are some problems connecting 1.4 and 1.3 JVMs. Because of the NIO stuff we made the build with JDK 1.4 RC by default for every distribution. I've changed that to 1.3.1 and everything is new generated. I can connect now without problems.

Please download the distribution again. Sorry, but there seems to be some incompatibilities between 1.4 and 1.3 class files.
About | Sitemap | Contact