Setting the CLASSPATH-variable under Linux RH.
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Bjornie_Wikstroem
Posted On:   Thursday, January 24, 2002 08:25 AM

Hi! I'm sitting on Linux RH7.2 and have some troubles with the classpath. In the file .bashrc I've added the lines: JAVA_HOME=/usr/java/j2sdk1.4.0; export JAVA_HOME PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/usr/java/j2sdk1.4.0/bin; export PATH CLASSPATH=/usr/java/j2sdk1.4.0/lib/tools.jar; /usr/java/j2sdk1.4.0/lib/jdom.jar; export CLASSPATH When I'm later starting the console, I get the errormessage: bash: /usr/java/j2sdk1.4.0/lib/jdom.jar: Access denied How can I solve the problem, I want to have the jdom.jar in my CLASSPATH! Regards, Bjornie Wikstroem bjorne@comma   More>>

Hi!


I'm sitting on Linux RH7.2 and have some troubles with the classpath.



In the file .bashrc I've added the lines:


JAVA_HOME=/usr/java/j2sdk1.4.0; export JAVA_HOME
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/usr/java/j2sdk1.4.0/bin; export PATH
CLASSPATH=/usr/java/j2sdk1.4.0/lib/tools.jar; /usr/java/j2sdk1.4.0/lib/jdom.jar; export CLASSPATH



When I'm later starting the console, I get the errormessage:


bash: /usr/java/j2sdk1.4.0/lib/jdom.jar: Access denied



How can I solve the problem, I want to have the jdom.jar in my CLASSPATH!


Regards,

Bjornie Wikstroem

bjorne@command.nu || bjorne.w@telia.com

   <<Less

Re: Setting the CLASSPATH-variable under Linux RH.

Posted By:   Jeff_Hubbach  
Posted On:   Thursday, January 24, 2002 03:02 PM

It looks like you might have a space in your CLASSPATH definition. Also, be sure to use colons, not semicolons, to separate values (semicolons are used on Windows boxes, but colons are used on Unix/Linux).



Jeff.
About | Sitemap | Contact