dcsimg
How to use DLLs with Visual Age´s Test Environment ?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Daniel_Almeida
Posted On:   Friday, January 18, 2002 09:01 AM

Hi, I hava a Java project that uses a DLL. When I use it (the DLL) at Websphere, I don´t have any kind of problem. But, when I use the Test Environment to debug my project, I have a problem on load that DLL. I am using Visual Age for Java 4.0 at Win NT Workstation 4.0. Where should I place the DLL ? The error message I´m having is: java.lang.UnsatisfiedLinkError: no mydllfile in java.library.path I´ve already checked my classpath and the Winntsystem32 directory is there. Thanks Daniel, Sao Paulo, Brasil.    More>>

Hi,

I hava a Java project that uses a DLL. When I use it (the DLL) at Websphere, I don´t have any kind of problem.

But, when I use the Test Environment to debug my project, I have a problem on load that DLL.

I am using Visual Age for Java 4.0 at Win NT Workstation 4.0.

Where should I place the DLL ?

The error message I´m having is:

java.lang.UnsatisfiedLinkError: no mydllfile in java.library.path

I´ve already checked my classpath and the Winntsystem32 directory is there.



Thanks


Daniel, Sao Paulo, Brasil.

   <<Less

Re: How to use DLLs with Visual Age&#180;s Test Environment ?

Posted By:   Steven_Martin  
Posted On:   Friday, January 18, 2002 11:14 AM

Is that the classpath for the IDE or the classpath for the individual program. Check the classpath of the websphere test environment to make sure the dll is in the path.

How are you using a dll? C native call?
About | Sitemap | Contact