Can't get JSPs to recompile
5 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anonymous
Posted On:   Thursday, January 17, 2002 04:16 PM

I'm running into a problem when I encounter a coding error in my jsp file, go and fix the error, save it, and try to access the page with my changes. The server (Tomcat 4.0) persists in giving me the old version of the file.


I tried 1) shutting down and restarting Catalina, then 2) shutting down, deleting the .java file for the page from workmyWebApp, and restarting. I'm still getting errors related to code that no longer exists in the page.


(I notice this same question is in the FAQ, but it's unanswered..)


Thank you,

Garann

Re: Can't get JSPs to recompile

Posted By:   Luigi_Viggiano  
Posted On:   Monday, May 27, 2002 01:04 AM

Also, set-up your browser to skip the proxy for your specific application, maybe the proxy is caching your page. If you still get the "old page", try adding a parameter to make caching impossible: let's say your page is http://yourhost.com/yourpage.jsp you should requeste the page as http://yourhost.com/yourpage.jsp?dummyparam=randomvalue . Where randomvalue is get randomly or from System.currentTimeMillis(). In this way the browser (and eventually the proxy) cannot get cached data due to a different parameter passed in the GET request.

Re: Can't get JSPs to recompile

Posted By:   Steve_Hanley  
Posted On:   Monday, March 11, 2002 10:01 AM

The content is probably being cached by the browser. To prevent odd problems like this you must expire all pages with dynamic content unless it's okay for the content to become stale.



Re: Can't get JSPs to recompile

Posted By:   Mahesh_Devendran  
Posted On:   Saturday, February 9, 2002 01:03 PM


Normally, if you are Beans in your JSP and if the class files are not loaded.
You may get this error.Try deleting the .class files and recompiling them into their place.
Also please post the code along with your question which would help us to answer your question better.


Regs
Mahesh

Re: Can't get JSPs to recompile

Posted By:   Luigi_Viggiano  
Posted On:   Monday, February 4, 2002 12:01 PM

Here are 2 hint you can apply to solve this problem:

  1. delete any jsp-generated file in the work directory. Then restart tomcat.
  2. check date on the computer running the JSP engine and your pc (they should match). check also dates on generated files and JSP (remove files with wrong date or date set on future).

Hope this helps.

~Luigi

Re: Can't get JSPs to recompile

Posted By:   Dave_Hemingway  
Posted On:   Thursday, January 17, 2002 10:25 PM

I have had this exact problem before, I did the exact same things that you did and teh only way i could fixed it was by removing teh file from the directory, attempting to access it still (of course getting a page not found error) then putting the file back, hitting refresh and everything was rosey, may sound ridiculous but it was the only thing i could do to get it to work, I have spoken to a few other people which have fixed it a similar way.
About | Sitemap | Contact