Error when trying to add a datasource.
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Bill_Ross
Posted On:   Wednesday, January 16, 2002 03:12 PM

When trying to add a DataSource in the WTE, I get the error: An error has occurred. Cannot retrieve DataSource list from the initial context. If the Persistent Name Server has not been started, please start it now. com.ibm.ivj.control.node.InitialContextNotFoundException: Unable to create initial context javax.naming.NoInitialContextException: Cannot instantiate class: com.ibm.ejs.ns.jndi.CNInitialContextFactory [Root exception is java.lang.ClassCastException] Even though I have already started my Persistent Name Server. Anyone else seen this? Thanks!    More>>

When trying to add a DataSource in the WTE, I get the error:


An error has occurred. Cannot retrieve DataSource list from the initial context.


If the Persistent Name Server has not been started, please start it now.


com.ibm.ivj.control.node.InitialContextNotFoundException: Unable to create initial context
javax.naming.NoInitialContextException: Cannot instantiate class: com.ibm.ejs.ns.jndi.CNInitialContextFactory [Root exception is java.lang.ClassCastException]


Even though I have already started my Persistent Name Server. Anyone else seen this?


Thanks!

   <<Less

Re: Error when trying to add a datasource.

Posted By:   Bill_Ross  
Posted On:   Friday, January 18, 2002 02:56 PM

Just a follow up for anyone interested. I found that the problem went away when I removed the Java SDK version 1.3.1 "rt.jar" file from the workspace classpath. I had added it when I was working on some classes that used version 1.3.1 classes.
About | Sitemap | Contact