dcsimg
re: newbie problems running Ant on windows 2000!
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Joe_Atkins
Posted On:   Wednesday, October 10, 2001 01:35 AM

I have set up my class path correctly.I have installed xerces xml parser instead of of crimson. There is a class on apache's webpage called "EnvironmentCheck.java" that checked out the classpath environment on my computer and said everything was ok. After all this when i try to run the batch file called ant from "C:Ant in>" for a trial run of "Ant" this is the result : C:Ant in>ant Exception in thread "main" java.lang.NoClassDefFoundError: %lib;C:xalanj22D11 xalan_xerces inxerces/jar;C:xalanj22D11xalan_xerces inxalan/jar;C:xalanj2 2D11xalan_xerces inxalansamples/jar;C:xalanj22D11xalan_xerces inxalan   More>>
			

I have set up my class path correctly.I have installed xerces xml parser instead of of crimson.
There is a class on apache's webpage called "EnvironmentCheck.java" that checked out the
classpath environment on my computer and said everything was ok.



After all this when i try to run the batch file called ant from "C:Ant in>"
for a trial run of "Ant" this is the result :


C:Ant in>ant
Exception in thread "main" java.lang.NoClassDefFoundError: %lib;C:xalanj22D11
xalan_xerces inxerces/jar;C:xalanj22D11xalan_xerces inxalan/jar;C:xalanj2
2D11xalan_xerces inxalansamples/jar;C:xalanj22D11xalan_xerces inxalanserv
let/jar;C:jdk1/3/1_01lib ools/jar;




Can some one let me know what is going on ?Appreciate any help !


   <<Less

Re: re: newbie problems running Ant on windows 2000!

Posted By:   Erik_Hatcher  
Posted On:   Wednesday, October 10, 2001 10:00 AM

It looks like your classpath is messed up. I see some forward slashes there, which might be the cause of the problem.

Re: re: newbie problems running Ant on windows 2000!

Posted By:   kola_fajimolu  
Posted On:   Wednesday, October 10, 2001 08:59 AM

check your path. Type path and the command line. Need a path back to ANT_HOMEin.
About | Sitemap | Contact