dcsimg
What version of Java does VAJ 4.0 support?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Sam_Newman
Posted On:   Tuesday, September 18, 2001 01:51 AM

We are currently using VAJ 3.5.x, which seems to support Java circa version 1.2.2 (via its UVM). We are hitting problems at the moment in that many bugs we are seeing in our swing interfaces are fixed in java 1.3 (and its a fairly long list). In addition we need to use some 1.3 specific code (especially for Actions). I know we cannot change the UVM, but I was considering using VAJ 4.0 in the hope it supports java 1.3 apis. As yet I am unable to find any reference to which version of java VAJ 4.0 supports - can anyone out there help me? I can put up with VAJ's other quirks if it means I get to keep using its Visual Composition, but not supporting 1.3 could be a serious issue. I would of posted this to the IBM newsgroups but they seem to be down at the moment (or my    More>>

We are currently using VAJ 3.5.x, which seems to support Java circa version 1.2.2 (via its UVM). We are hitting problems at the moment in that many bugs we are seeing in our swing interfaces are fixed in java 1.3 (and its a fairly long list). In addition we need to use some 1.3 specific code (especially for Actions). I know we cannot change the UVM, but I was considering using VAJ 4.0 in the hope it supports java 1.3 apis. As yet I am unable to find any reference to which version of java VAJ 4.0 supports - can anyone out there help me? I can put up with VAJ's other quirks if it means I get to keep using its Visual Composition, but not supporting 1.3 could be a serious issue. I would of posted this to the IBM newsgroups but they seem to be down at the moment (or my fireall is blocking access).

Thanks in advance,
sam

   <<Less

Re: What version of Java does VAJ 4.0 support?

Posted By:   Jack_Mirp  
Posted On:   Tuesday, September 18, 2001 03:44 AM

I´m sorry sam, VAJ 4.0 does only support java 1.2.2. You can see it in VAJ
4.0 when you go on help and info. Java 1.3. will be supportet in the new
IDE from IBM called Eclipse. The beta version of Eclipse is avaible on IBM
WebSites.
About | Sitemap | Contact