Error in applet using an array!:!_NEWLINE_!!_NEWLINE_!java.lang.ClassNotFoundException: java.util.Arrays
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Ezequiel_Glinsky
Posted On:   Thursday, June 7, 2001 11:20 AM

I have an applet, signed and everything works fine. But when I try to do the following: (...) int[] e=new int[4]; e[0]=101; e[1]=54; e[2]=60; e[3]=20; Arrays.sort(e); // This line is the number 161 (...) I receive the following: Exception occurred during event dispatching: java.lang.ClassNotFoundException: java.util.Arrays at com/ms/vm/loader/URLClassLoader.loadClass (URLClassLoader.java) at java/lang/ClassLoader.loadClassInternal (ClassLoader.java) at GrafLog.initialize (graflog.java:161)    More>>

I have an applet, signed and everything works fine.

But when I try to do the following:




(...)

int[] e=new int[4];

e[0]=101;

e[1]=54;

e[2]=60;

e[3]=20;



Arrays.sort(e); // This line is the number 161

(...)









I receive the following:



Exception occurred during event dispatching:

java.lang.ClassNotFoundException:
java.util.Arrays
at com/ms/vm/loader/URLClassLoader.loadClass (URLClassLoader.java)

at java/lang/ClassLoader.loadClassInternal (ClassLoader.java)

at GrafLog.initialize (graflog.java:161)

at GrafLog.actionPerformed (graflog.java:396)

at java/awt/Button.processActionEvent (Button.java)

at java/awt/Button.processEvent (Button.java)

at java/awt/Component.dispatchEventImpl (Component.java)

at java/awt/Component.dispatchEvent (Component.java)

at java/awt/EventDispatchThread.run (EventDispatchThread.java)







What is wrong? Do I have to do something special to use those Array's
methods?



Thanks in advance!

Ezequiel.



--

Ezequiel Glinsky

eglinsky@bumeran.com

   <<Less

Re: Error in applet using an array!:!_NEWLINE_!!_NEWLINE_!java.lang.ClassNotFoundException: java.util.Arrays

Posted By:   John_Zukowski  
Posted On:   Friday, June 8, 2001 11:25 AM

The Arrays class is part of Java 1.2. As already answerded in the FAQ, the runtime that comes with the browsers is 1.1 based.
About | Sitemap | Contact