I cannot compile ANTLR on Linux with gcc 2.95.3 and the SGI STL
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Bruno_Koechlin
Posted On:   Wednesday, May 30, 2001 09:12 AM

Hello,

I repost my question without the whole compiler error
because I got an error when I posted it with the error.

On Linux redhat 6.2, with gcc 2.95.3 and the
SGI standart library, I get an error when I try
to compile TokenStreamSelector.cpp:

/usr/local/sgi_stl/container_concepts.h:216: parse error before `>'

I don't have this error with the gnu STL that is
unfortunatly buggy in a function I need.

Has somebody met this problem and found a solution ?

Thanks
Bruno

Re: I cannot compile ANTLR on Linux with gcc 2.95.3 and the SGI STL

Posted By:   Ric_Klaren  
Posted On:   Thursday, May 31, 2001 01:55 AM

Maybe try STLPort in stead of the SGI stl. Or upgrade the RH6.2 gcc to the one of RH7.1 (with all depending packages). The RH7.1 one is a 'stablish' cvs snapshot (pre gcc3). It should behave pretty ok.

Ric

About | Sitemap | Contact