How to use tomcat as ISS filter on WIN 2000?
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   M_Ni
Posted On:   Monday, April 30, 2001 03:54 AM

Hi, I'm trying to use tomcat as servlet engine on IIS. Tomcat alone works fine, but i can't make the ISS to use the tomcat. I have followed intructions at "http://jakarta.apache.org/tomcat/jakarta-tomcat/src/doc/tomcat-iis-howto.html", but when I add isapi_redirect.dll as a filter for ISS, the filter is marker with red down-pointing arrow, not green up-pointing. All the entries in the registry should be correct. Should the examples work with default workers- and uniworkermap- properties files? If I access the tomcat without ISS (localhost:8080/examples/jsp/index.html, everything works fine. I'm using windows 2000 server. I have some other sites (with own domainnames) as well on the IIS (on s   More>>

Hi,


I'm trying to use tomcat as servlet engine on IIS. Tomcat alone works fine, but i can't make the ISS to use the tomcat. I have followed intructions at "http://jakarta.apache.org/tomcat/jakarta-tomcat/src/doc/tomcat-iis-howto.html", but when I add isapi_redirect.dll as a filter for ISS, the filter is marker with red down-pointing arrow, not green up-pointing. All the entries in the registry should be correct.


Should the examples work with default workers- and uniworkermap- properties files? If I access the tomcat without ISS (localhost:8080/examples/jsp/index.html, everything works fine.

I'm using windows 2000 server. I have some other sites (with own domainnames) as well on the IIS (on same IP-number), can this cause some problems? Static pages works well on every site.


Anyone have solution for this problem? Or suggestions for some other servlet engine (free) for IIS. Thanks,


-- MNi

   <<Less

Re: How to use tomcat as ISS filter on WIN 2000?

Posted By:   M_Ni  
Posted On:   Monday, April 30, 2001 05:22 AM

YES!


I finally figured it out. When I had entered stuff to the registry I have extra space in the registry key name. (Ie. "worker_file " when it should have been "worker_file").


No the arrow is pointing up and it's green! Hope this helps others too.


--
MNi

About | Sitemap | Contact