Problem with mod_jk.so
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Arun_Rajamohan
Posted On:   Thursday, April 5, 2001 03:00 AM

Hi!
I have downloaded binary distribution of tomcat-3.2.1 and also mod_jk.so adapter. I tried copying the mod_jk.so file into the libexec directory of apache and also added it in the LoadModule tags in the httpd.conf file followed by the "include path/to/mod_jk.conf-auto".
I get an error msg that the load module tag for jk_module is not valid.I know that there should be mod_jk.c and lod_jk.dsp file.
But where do i find the mod_jk.c and mod_jk.dsp file?? how should i configure ???

Re: Problem with mod_jk.so

Posted By:   Hans_Buchwalt  
Posted On:   Monday, May 7, 2001 02:09 AM

Hey

Sorry my bad English. The mod_jk.c is made on the fly.
But I have an similar problem explained below.


I tried to configure the mo_jk.so into the apache server. So I red the instructions in the
/doc/directory special "mod_jk_howto.html#s6" in the jakarta directory. There are 6 steps
to do. But I had some trobble.

1.) i have apxs runnig
2.) change dircetory to jakarta-tomcat/src/native/apache1.2
this dir. does not exist in my path - instead src/org/apache is given ?
3.) Then I run the command for Linux:
"apxs -o mod_jk.so -I../jk -I/usr/local/jdk/include -I/usr/lokal/jdk/include/linux/ -c *.c ../jk/*.c"
but what is ../jk this directory dosnĀ“t exist???
bash:gcc -DLINUX=22 -DUSE_HSREGEX -DUSE_EXPAT
-I../lib/expat-lite -fpic -DSLE -I/usr/local/apache/include
-I../jk/ -I/usr/local/jdk1.3/include/
-I/jdk1.3/include/linux/ -c *.c
gcc: *.c: File or Directory not found
gcc: No input files
apxs:Break: Command failed with rc=1

4.) Step 4: I put these line but it shows me:
gcc -shared -o mod_jk.so *.o
gcc: *.o: File or Directory not found
gcc: No input files


Then I append the line:
"Include /usr/local/jakarta-tomcat/con/mod_jk.conf-auto"
in the httpd.conf of apache.
Then I copied mod_jk.so into the libexec/ directory of apache
and restart first tomcat than apache.

But this is the error-statment:
Syntax error on line 8 of
/usr/local/jakarta-tomcat/conf/mod_jk.conf-auto API module
structure 'jk_module' in file
/usr/local/apache/libexec/mod_jk.so is garbled - perhaps this
is not an Apache module DSO?
After this the following lines are printed on console:
Context Manger: Adding context Ctx(/examples)
Context Manger: Adding Context Ctx(/admin)
Starting tomcat. Check logs/tomcat.log for error massages
Context Manger: Adding context Ctx (/test)
PoolTopConnector: Starting HttpConnectionHandler on 80000
PoolTcpConnector: Starting Ajp12 ConnectionHandler on 8007

--- that is all--

I think the error is on crating the mod_jk.c file!?
First I have to creat this but how???
Maybe I need also a entry in httpd.conf: ??
AddModule mod_jk.c


I need urgently help!!!!:(
Alfipost@hotmail.com

Re: Problem with mod_jk.so

Posted By:   AlessandroA_Garbagnati  
Posted On:   Thursday, April 5, 2001 08:51 AM

Arun,

yes, I've had the same problem and I've recompiled the mod_jk.so module by myself, following the instructions I've found in the Mod_jk: How To.

By the way, you need the source distribution of Tomcat for recompiling the module.
About | Sitemap | Contact