dcsimg
Tomcat+IIS cofiguration-problem ?
2 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Anonymous
Posted On:   Wednesday, March 21, 2001 11:46 AM

Hi all. I'm pretty new in here and so I don't know if there was previously this question. When I call a JSP-Page twice I get a double response. I have a user-login-page (login.jsp) with a form on it. When I submit this form I call the login.jsp for the second time. The JSP-Page decides to login the user or not. If the user can login, the login.jsp redirects the user to another page. If he can't login the login.jsp with it's form will be displayed. Everything works fine on Tomcat as stand-alone. But if I disable the Http-Tomcat-service and use the IIS instead, it seems that the IIS saves the Html-code of the login.jsp from the first request and send this code due to the second request from the form-action to the clients-browser.    More>>

Hi all.
I'm pretty new in here and so I don't know if there was previously this question.

When I call a JSP-Page twice I get a double response.
I have a user-login-page (login.jsp) with a form on it. When I submit this form I call the login.jsp for the second time. The JSP-Page decides to login the user or not. If the user can login, the login.jsp redirects the user to another page. If he can't login the login.jsp with it's form will be displayed.
Everything works fine on Tomcat as stand-alone. But if I disable the Http-Tomcat-service and use the IIS instead, it seems that the IIS saves the Html-code of the login.jsp from the first request and send this code due to the second request from the form-action to the clients-browser. A second later the tomcat has finished his work and sends also his code to the client-browser, so I get two pages in one browser-window. Very funny and annoying.
Huuh long story -- If someone can help...

   <<Less

Re: Tomcat+IIS cofiguration-problem ?

Posted By:   Vimal_Gandhi  
Posted On:   Monday, July 30, 2001 06:09 AM

Hello both,
You both can use tag insted of sendRedirect ok...
try it
VM

Re: Tomcat+IIS cofiguration-problem ?

Posted By:   jc_bernard  
Posted On:   Wednesday, April 4, 2001 06:15 AM

Hi,

I meet exactly this pb with the same config, when i use a respons.sendRedirect in jsp page.

So if you receive or find solution,
please let me know...

Thanks

you can mail to : jcbernard@free.fr
About | Sitemap | Contact