Can't install TPTP for Eclipse 3.3.1 apparently because of missing RCP feature
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   David_Vergnaud
Posted On:   Wednesday, July 1, 2009 10:48 AM

Hi everyone! I've been trying to install the TPTP plugin for Eclipse (Eclipse Europa 3.3.1.1 running on Windows XP SP2) using the Update Manager, but it somehow fails due to some missing RCP component. Here are the steps I've been following: Help>Software Updates/Find and Install... Search for new features to install Next Here, as explained on the TPTP Install Guide , I added the new remote site, selected "TPTP" and clicked on Finish The list of features is retrieved, and a category "TPTP Update Site" is displayed in the search results, with many different versions listed under it. If I select the new one (TPTP 4.6.0 Features) with its whole content, then Eclipse   More>>

Hi everyone!


I've been trying to install the TPTP plugin for Eclipse (Eclipse Europa 3.3.1.1 running on Windows XP SP2) using the Update Manager, but it somehow fails due to some missing RCP component. Here are the steps I've been following:



  • Help>Software Updates/Find and Install...

  • Search for new features to install

  • Next

  • Here, as explained on the TPTP Install Guide , I added the new remote site, selected "TPTP" and clicked on Finish

  • The list of features is retrieved, and a category "TPTP Update Site" is displayed in the search results, with many different versions listed under it. If I select the new one (TPTP 4.6.0 Features) with its whole content, then Eclipse displayed an error message:


			Eclipse RCP Patch 1 for 3.3.1 (3.3.1.v20071002_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0GlHJrXvTAUS)".
			

and all buttons are disabled save for "Cancel".


I've tried to locate and install this feature, but the best I could find was an RCP Patch 2, which complains that it cannot be installed because Patch 1 cannot be found (or something like that). I have absolutely not been able to find any package or patch I could install and start with.


Could anybody tell me what I should do now, or where I could find the components I need to meet TPTP's requirements?


Thanks folks!


David

   <<Less

Re: Can't install TPTP for Eclipse 3.3.1 apparently because of missing RCP feature

Posted By:   David_Vergnaud  
Posted On:   Wednesday, July 1, 2009 11:48 AM

Actually the problem with the RCP didn't have anything to do with TPTP -- apparently my installation was somehow corrupt, and removing the problematic feature allowed me to complete the TPTP installation o/
About | Sitemap | Contact