dcsimg
Applet not inited problem
1 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   Harish_Gokul
Posted On:   Monday, November 3, 2008 09:17 AM

Hi, I am adding an applet in a JSP page using an external javascript file. And I am constructing the Applet code based on the browser family ( for Mozilla family and for MS-Internet Explorer). JavaScript: var _app = navigator.appName; if (_app == 'Mozilla' || _app == 'Netscape') { document.write(' 'width="200"', 'height="200"', 'type="application/x-java-applet;version=1.5"', 'pluginspage="pluginspage="http://java.sun.com/javase/downloads/ea.jsp"', 'archive="Appln.jar">'); } else if (_app == 'Microsoft Internet Explorer') { document.write(' 'cla   More>>

Hi,

I am adding an applet in a JSP page using an external javascript file. And I am constructing the Applet code based on the browser family (

for Mozilla family and for MS-Internet Explorer).

JavaScript:
var _app = navigator.appName;
if (_app == 'Mozilla' || _app == 'Netscape')
{
document.write('
'width="200"',
'height="200"',
'type="application/x-java-applet;version=1.5"',
'pluginspage="pluginspage="http://java.sun.com/javase/downloads/ea.jsp"',
'archive="Appln.jar">');
}
else if (_app == 'Microsoft Internet Explorer')
{
document.write('
'classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"',
'width="200"',
'height="200">',
' ',
'archive="Appln.jar"',
'
');
}
else
{ document.write('

Sorry, unsupported browser.

'); }

I have JARed the applet program. I placed the jar file in the same place where my JSP page exists. I am getting an error msg in the browser's status bar --> applet ButtonMoveApplet notinited when I run this from the browser (http://localhost:8080/AppletApplication). When I checked in Java Console I found java.lang.ClassNotFoundException.

My office network is configured to use a proxy. Is the browser doesnÂ’t allow to load the applet because of the proxy? Or is there any other problem?

Any help on this will be greatly appreciated

Regards,
Red Hunt
   <<Less

Re: Applet not inited problem

Posted By:   shiva_shankar  
Posted On:   Thursday, December 11, 2008 12:33 AM

did you try with MSJVM....the defaut sunjvm is not allowing some of tags to function propperly...

i faced the similar issue..


i donwloaded MSJVM and installed... and the Applet is working fine....
About | Sitemap | Contact