Running ANT - Error: ANT_HOME is set incorrectly or ant could not be located. Please set ANT_HOME.
3 posts in topic
Flat View  Flat View
TOPIC ACTIONS:
 

Posted By:   mel_tan
Posted On:   Thursday, August 7, 2008 09:19 AM

I'm a newbie and am trying to self-learn. I've tried to get ANT to run by following instructions from the homepage. 1. Downloaded apache-ant-1.7.1-bin.zip and unziped ANT 1.7.1 onto C:Apache-Ant 2. Set environment settings in Vista>System>Advance System Settings>Environment Variables>System Variables ANT_HOME C:Apache-Ant in PATH C:Apache-Ant in 3. To check my settings using "SET" in command prompt. The output: ANT_HOME=C:Apache-Ant in CommonProgramFiles=C:Program FilesCommon Files FP_NO_HOST_CHECK=NO JAVA_HOME=C:Program FilesJavajdk1.6.0_07 in NUMBER_OF_PROCESSORS=4 OS=Wind   More>>

I'm a newbie and am trying to self-learn. I've tried to get ANT to run by following instructions from the homepage.

1. Downloaded apache-ant-1.7.1-bin.zip and unziped ANT 1.7.1 onto C:Apache-Ant

2. Set environment settings in Vista>System>Advance System Settings>Environment Variables>System Variables

ANT_HOME C:Apache-Ant in

PATH C:Apache-Ant in


3. To check my settings using "SET" in command prompt. The output:

ANT_HOME=C:Apache-Ant in

CommonProgramFiles=C:Program FilesCommon Files

FP_NO_HOST_CHECK=NO

JAVA_HOME=C:Program FilesJavajdk1.6.0_07 in

NUMBER_OF_PROCESSORS=4

OS=Windows_NT

Path=C:Windowssystem32;C:Windows;C:WindowsSystem32Wbem;C:Program FilesQu
ickTimeQTSystem;C:PROGRA~1DISKEE~1DISKEE~1;C:Apache-Ant in

PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

PROCESSOR_ARCHITECTURE=x86

PROCESSOR_IDENTIFIER=x86 Family 6 Model 23 Stepping 7, GenuineIntel

PROCESSOR_LEVEL=6

PROCESSOR_REVISION=1707

TEMP=C:UsersMelvinAppDataLocalTemp

TMP=C:UsersMelvinAppDataLocalTemp

windir=C:Windows


4. I checked that installation is complete, C:Apache-Antlib included among other files:

ant.jar

ant-launcher.jar



5. When I run ANT.bat, the following is reported "ANT_HOME is set incorrectly or ant could not be located. Please set ANT_HOME."

Please help. I just cannot get to the root of the problem. I've checked the FAQ/WIKI/Forums. No luck so far.

Thank you very much.

   <<Less

Re: Running ANT - Error: ANT_HOME is set incorrectly or ant could not be located. Please set ANT_HOME.

Posted By:   Robert_Lybarger  
Posted On:   Thursday, September 4, 2008 08:59 AM

Unless something has changed recently, "ANT_HOME" should *not* include the "bin" directory part. (The "PATH" var however will.)

Re: Running ANT - Error: ANT_HOME is set incorrectly or ant could not be located. Please set ANT_HOME.

Posted By:   Anonymous  
Posted On:   Thursday, September 4, 2008 01:23 AM

ANT_HOME=C:Program Filesapache-ant-1.7.0in
path=C:Program Filesapache-ant-1.7.0in;

Re: Running ANT - Error: ANT_HOME is set incorrectly or ant could not be located. Please set ANT_HOME.

Posted By:   zhaohua_meng  
Posted On:   Thursday, August 7, 2008 01:39 PM

Your ANT_HOME should be set to C:Apache-Ant, not C:Apache-Antin
About | Sitemap | Contact